Unable to process Cable Subscription payments
Incident Report for SeamPay
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 09:08 BST
Update
We are continuing to investigate this issue.
Posted Oct 22, 2021 - 05:44 BST
Investigating
We are currently investigating an issue where Cable Subscription payments are not being processed. We've engaged the relevant partner to resolve this issue.
Posted Oct 22, 2021 - 05:43 BST
This incident affected: Payments (Cable Subscription).